【笨方法学PAT】1050 String Subtraction (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83302455

一、题目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

二、题目大意

给定两个字符串,求差

三、考点

string

四、注意

1、包含空格,使用getline;

2、使用map保存字符是否出现。

五、代码

#include<iostream>
#include<string>
#include<unordered_map>
using namespace std;
int main() {
	//read
	string s1, s2;
	getline(cin, s1);
	getline(cin, s2);

	//solve
	unordered_map<char, int> un_map;
	for (int i = 0; i < s2.length(); ++i) 
		un_map[s2[i]] = 1;
	
	//output
	for (int i = 0; i < s1.length(); ++i) {
		if (un_map[s1[i]] == 0)
			cout << s1[i];
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83302455