PAT (Advanced Level) Practice A1044 Shopping in Mars (25 分)(C++)(甲级)(二分法)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86554846

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5 ), the total number of diamonds on the chain, and M (≤108 ), the amount that the customer has to pay. Then the next line contains N positive numbers D​1⋯DN (Di≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:

1-5
4-6
7-8
11-11
Sample Input 2:

5 13
2 4 5 7 9
Sample Output 2:

2-4
4-5

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct result
{
    int last;
    int sum;
}result;

result R[100010] = {0};//存放从第i+1位到last位序列的累加和

int Sum[100010] = {0};//从第一位到第i位的累加和存储在Sum的第i位
int smallest = 0;//满足sum>M的sum最小值

int N, M;

int main()
{
    int i, l, r, mid, temp_sum;
    scanf("%d %d", &N, &M);
    for(i=1; i<=N; i++)
    {
        scanf("%d", &Sum[i]);
        Sum[i] = Sum[i-1] + Sum[i];
    }
    for(i=0; i<N; i++)
    {
        l = i, r = N;
        while(l <= r && R[i].sum != M)//二分法
        {
            mid = l + (r-l)/2;
            temp_sum = Sum[mid] - Sum[i];
            if(temp_sum >= M && (!R[i].sum || temp_sum<R[i].sum))
            {
                R[i].sum = temp_sum;
                R[i].last = mid;
            }
            if(temp_sum > M) r = mid-1;
            else l = mid+1;
        }
        if(!smallest || R[i].sum && R[i].sum < smallest) smallest = R[i].sum;//找到大于M的连续序列最小和
    }
    for(i=0; i<N; i++)//比较输出
    {
        if(R[i].sum == smallest)
        {
            printf("%d-%d\n", i+1, R[i].last);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86554846
今日推荐