《算法笔记》3.6小节——入门模拟->字符串处理 问题 G: 比较字符串

版权声明:copyright©CodeIover reserved https://blog.csdn.net/qq_40073459/article/details/86572482

                                          问题 G: 比较字符串

题目描述

输入两个字符串,比较两字符串的长度大小关系。

输入

输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。

输出

输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。

样例输入

2
abc xy
bbb ccc

样例输出

abc is longer than xy
bbb is equal long to ccc


实现代码:

#include<stdio.h> 
#include<string.h>
int main(){
    int m;
    char A[201],B[201];
    while(scanf("%d",&m)!=EOF)
    {
      while(m--)
      {
    	scanf("%s %s",A,B);
    	int len1=0,len2=0;
    	len1=strlen(A);
    	len2=strlen(B);
    	if(len1-len2==0) printf("%s is equal long to %s\n",A,B);
    	else if(len1-len2<0 ) printf("%s is shorter than %s\n",A,B);
    	      else if(len1-len2>0) printf("%s is longer than %s\n",A,B);
	  }
   }
    return 0;
}

结果如下:

猜你喜欢

转载自blog.csdn.net/qq_40073459/article/details/86572482