统计一行文本的单词个数

本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。

输入格式:

输入给出一行字符。

输出格式:

在一行中输出单词个数。

输入样例:

Let's go to room 209.

输出样例:

5
#include<stdio.h>
int main(){
	char s[100];
	gets(s);
	int i=0,n=0,flag=0;
	if(s[0]!=' '){
		flag=1;
	}
	while(s[i]!='\0'){
		if(s[i]==' '&&(s[i+1]!=' '&&s[i+1]!='\0')){
			n++;
		}
		i++; 
	}
	if(flag==1&&n>=1){
		n++;
	}
	printf("%d",n);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41376345/article/details/85176913