1094 The Largest Generation (25 分)找最多孩子的那一层的深度和宽度

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root IDto be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题意:

            给一棵家族树,找最多孩子的那一层的深度和宽度

思路:

            dfs,并且用一个数组来累计该层的孩子数目,注意递归边界是到叶子结点即不含有孩子

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1000;
struct Node
{
	int layer;
	vector<int>child;
}node[maxn];
int depth[maxn]={0};
void dfs(int root,int deep)
{
	node[root].layer=deep;
	depth[deep]+=1;//每层循环就在该层加一个孩子数目 
	if(node[root].child.size()==0)
	return;
	for(int i=0;i<node[root].child.size();i++)
	{
		dfs(node[root].child[i],deep+1); 
	}
}
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++)
	{
		int id,k,chi;
		scanf("%d%d",&id,&k);	
		for(int j=0;j<k;j++)
		{
			scanf("%d",&chi);
			node[id].child.push_back(chi);
		}
	}
	dfs(1,1);
	int maxnum=0,maxg;//最大人数,是哪代 
	for(int i=1;i<=n;i++)
	{
		if(depth[i]>maxnum)
		{
			maxnum=depth[i];
			maxg=i; 
		} 
	}
	printf("%d %d",maxnum,maxg);
}

猜你喜欢

转载自blog.csdn.net/qq_40916491/article/details/88017593