【NEEPU OJ】1023--Knight Moves

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34072526/article/details/88175849

Description

Alice is doing research on the Traveling Knight Problem(TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. She thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the”difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a…h) representing the column and a digit (1…8) representing the row on the chessboard.

Output

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

输入样例 1

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

输出样例 1

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

来源

UVa


代码

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int dx[] = {-2, 2, -2, 2, 1, 1, -1, -1};
const int dy[] = {1, 1, -1, -1, -2, 2, -2, 2};
int vis[10][10];

struct node{
	int x, y;
}start, over;

int bfs(){
    if(start.y == over.y && start.x == over.x) return 0;
    memset(vis, 0, sizeof(vis));
	queue<node> q;
	int i;
	q.push(start);
	while(!q.empty()){
	    node t1 = q.front();
	    q.pop();
	    for(i = 0; i < 8; i++){
	        node t2;
	        t2.x = t1.x + dx[i];
	        t2.y = t1.y + dy[i];
	        if(t2.x >= 1 && t2.x <= 8 && t2.y >= 1 && t2.y <= 8 && !vis[t2.y][t2.x]){
	        vis[t2.y][t2.x] = vis[t1.y][t1.x] + 1;
	        if(t2.y == over.y && t2.x == over.x) return vis[t2.y][t2.x];
	        q.push(t2);
	        }
	    }
	}
	return -1;
}

int main(){
	char sy, oy;
	while(~scanf("%c%d %c%d%*c", &sy, &start.x, &oy, &over.x)){
	    start.y = sy - 96;
	    over.y = oy - 96;
	    printf("To get from %c%d to %c%d takes %d knight moves.\n", sy, start.x, oy, over.x, bfs());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34072526/article/details/88175849
今日推荐