lightoj1005组合数学

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.

Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x nchessboard so that no two of them are in attacking positions.

Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

从n行里取k个,从n列里取k个,再排列即可 

#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
int t;
ll n,k;
ll getc(ll n,ll m)
{
    if(n<m)
        return 0;
    if(m>n-m)
        m=n-m;
    ll s1=1,s2=1;
    for(ll i=0;i<m;i++)
    {
        s1=s1*(n-i);
        s2=s2*(i+1);
        if(s1%s2==0)
        {
            s1=s1/s2;
            s2=1;
        }
    }
    s1=s1/s2;
    return s1;
}
int main()
{

    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        scanf("%lld%lld",&n,&k);

        ll ans=getc(n,k)*getc(n,k);
        for(int i=1;i<=k;i++)
            ans*=i;
        printf("Case %d: %lld\n",w,ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88756051