HDU --- 4745 Two Rabbits(最长回文子序列 区间DP)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37868325/article/details/88574677

题意:

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai. 

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise. 

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise. 

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone. 

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.

Input

The input contains at most 20 test cases. 
For each test cases, the first line contains a integer n denoting the number of stones. 
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000) 
The input ends with n = 0.

Output

For each test case, print a integer denoting the maximum turns.

Sample Input

1
1
4
1 1 2 1
6
2 1 1 2 1 3
0

Sample Output

1
4
5

思路:

这个题理解的并不十分透彻,求最长回文序列是比较容易想到的,,但是弄成区间dp的求解方式是没有想到的。。

dp[i][j]表达的是区间【i,j】内最长的回文子序列。,然后从小区间推到大区间,

最后枚举起点,也可能是两个回文串,然后各绕一圈。。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<set>
#include<cmath>
#include<map>
#include<vector>
#include<iomanip>
using namespace std;
const int N=20;
int n,m,a[1005];
int dp[1005][1005];
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i][i]=1;
        }
        for(int l=1;l<=n;l++)
        {
            for(int i=1,j=l+1;j<=n;j++,i++)
            {
                if(a[i]==a[j]) dp[i][j]=dp[i+1][j-1]+2;
                else
                    dp[i][j]=max(dp[i+1][j],dp[i][j-1]);
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,dp[1][i]+dp[i+1][n]);
        }
        printf("%d\n",ans);
    }

	return 0;
 }

猜你喜欢

转载自blog.csdn.net/qq_37868325/article/details/88574677