POJ 3061(尺取法)

题目描述:

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

input:

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

output:

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

sample input:

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

sample output:

2
3

分析:

就是一道简单的尺取,意思是第一行是输入的组数,然后每组2行数,第一行两个数你n,s. n代表的是接下来一行有n个数,s代表的是你要取一段连续的数,这段数要大于s,同时使这段数的数字的个数最小,如果全部的数加起来小于s,那么输出0.

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
using namespace std;
int v[100005];
int main()
{
    int t,n,s;
    scanf("%d",&t);

    while(t--)
    {

        scanf("%d%d",&n,&s);
        int step=0;
        for(int a=1;a<=n;a++)
        {
            scanf("%d",&v[a]);
        }
        int j=1,k=1,sum=v[1];//j表示这一段数的头,k记录一段数的尾,sum记录这段数的每个数的值的和
        int ans=100000;//用来判断是否存在一段数大于等于题目给的数,如果存在,同时记录了最小的长度
        while(j<=k&&k<=n)
        {
            if(sum>=s)
            {
             if(sum-v[j]>=s)
             {
                 sum-=v[j++]; //让头往后面移,让这段数往后面遍历
             }
             else
             {
                 ans=min(ans,k-j+1);//记录最小长度
                 sum-=v[j++];
             }

            }

            else
            {
                sum+=v[++k];//这段数的总值不够的话让尾继续向后面扩展
            }
        }
        if(ans==100000)
        {
            printf("0\n");
        }
        else
        {
            printf("%d\n",ans);
        }

    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44122831/article/details/88390975