dp思维题

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <math.h>
#define INF 1e8
 
using namespace std;
int n,l;
int t[40],tt[40];
int dp[300];
int main(void)
{
    while (scanf("%d %d",&n,&l)!=EOF)
    {
        for (int i = 0;i < n;i++)
        {
            scanf("%d %d",&t[i],&tt[i]);
        }
        memset(dp,0,sizeof(dp));
        for (int i = 0;i < n;i++)
        {
            for (int j = t[i];j < 300;j++)
            {
                dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*tt[i]);
                if(dp[j]>=l)
                    break;
            }
        }
        for (int i = 0;i < 300;i++)
        {
            if(dp[i]>=l)
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/weixin_42165786/article/details/88857087
今日推荐