POJ 1905 Expanding Rods(二分)

Problem Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input    

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output 

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input 

1000 100 0.0001

15000 10 0.00006

10 0 0.001

-1 -1 -1

Sample Output 

61.329

225.020

0.000

题意: 

当一根长度为l的细杆被加热n度时,它会扩展到一个新的长度l'=(1+n*c)*l,其中c是热膨胀系数。              

当一根细杆安装在两个实心壁上然后加热时,它会膨胀并呈圆形节段,原来的杆是节段的弦。            

 你的任务是计算杆中心位移的距离。

思路:

如图,蓝色为杆弯曲前,长度为L。  红色为杆弯曲后,长度为s。

依题意知 ,S=(1+n*C)*L,又从图中得到三条关系式;

(1)      θr = 1/2*s

(2)      sinθ= 1/2*L/r

(3)       r^2 – ( r – h)^2 = (1/2*L)^2

化简得:

h的范围为  0<=h<1/2L

这样每次利用下界low和上界high就能得到中间值mid,寻找最优的mid使得(2)式左右两边差值在精度范围之内,那么这个mid就是h

 

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{

    double l,n,c;
    while(cin>>l>>n>>c)
    {
       if(l<0&&n<0&&c<0)
       break;
       double low=0.0;
       double high=0.5*l;
       double s=(1+n*c)*l;
       double mid;
       while(high-low>1e-6)
       {
           mid=(low+high)/2;
           double r=(4*mid*mid+l*l)/(8*mid);
           double t=2*r*asin(l/(2*r));
           if(t<s)
           low=mid;
           else
            high=mid;
       }
       cout<<fixed<<setprecision(3)<<mid<<endl;
     }
     return 0;
}


 

 


 

猜你喜欢

转载自blog.csdn.net/wcxyky/article/details/90116338