HDUOJ2052:Picture

版权声明:qq836678589 https://blog.csdn.net/weixin_43924623/article/details/90902752

Picture

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42618 Accepted Submission(s): 20640

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
3 2

Sample Output
±–+
| |
| |
±–+

#include<iostream>
using namespace std;
int main(){
	int n,m,i,j;
	while(cin>>m>>n){
		cout<<"+";
		for(i=1;i<=m;i++)	
		cout<<"-";
		cout<<"+"<<endl;
		for(i=0;i<n;i++){
			cout<<"|";
			for(j=0;j<m;j++)
				cout<<" ";
				cout<<"|"<<endl;
		}
		cout<<"+";
		for(i=1;i<=m;i++)
			cout<<"-";
		cout<<"+"<<endl;
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43924623/article/details/90902752
今日推荐