HDU2052 Picture

Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
 
  
3 2
 
Sample Output
 
  
+---+
|   |
|   |
+---+
#include<stdio.h>
int main()
{
   int n,m,t,i;
   while(scanf("%d%d",&n,&m)!=EOF)
   {
       for(t=1;t<=m+2;t++)
       {
           if(t==1||t==m+2)
           {
               for(i=1;i<=n+2;i++)
               {
                   if(i==1||i==n+2)
                    printf("+");
                   else
                    printf("-");
               }
               printf("\n");
           }
           else
           {
               for(i=1;i<=n+2;i++)
               {
                   if(i==1||i==n+2)
                    printf("|");
                   else
                    printf(" ");
               }
               printf("\n");
           }
       }
     printf("\n");
   }
   return 0;
}



猜你喜欢

转载自blog.csdn.net/narzisen/article/details/80217041
今日推荐