技巧+暴力

http://acm.hdu.edu.cn/showproblem.php?pid=4027

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 33385    Accepted Submission(s): 8020


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 
Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 
Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 
Sample Output
Case #1: 19 7 6
 
Source
 
Recommend
lcy
 注意到一个很大的数开6-7方根为1,所以对于r-l+1 == val 区间不需再更新,而其它递归到叶子逐个更新
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdio.h>
#include <queue>
#include <stack>;
#include <map>
#include <set>
#include <string.h>
#include <vector>
#define ME(x , y) memset(x , y , sizeof(x))
#define SF(n) scanf("%d" , &n)
#define rep(i , n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 1000000007
#define PI acos(-1)
using namespace std;
typedef long long ll ;
const int N = 100009;
ll sum ;

struct node
{
    int l , r ;
    ll val ;
}tree[N<<2];

void build(int l , int r , int root)
{
    tree[root].l = l , tree[root].r = r ;
    if(l == r)
    {

        scanf("%lld" , &tree[root].val);
        return ;
    }
    int mid = (l + r) >> 1 ;
    build(l , mid , root*2);
    build(mid+1 , r , root*2+1);
    tree[root].val = tree[root*2].val + tree[root*2+1].val ;
}

void update(int l , int r , int root)
{
    if((tree[root].l >= l && tree[root].r <= r) && (tree[root].r - tree[root].l + 1 >= tree[root].val))
    {
        return ;
    }
    if(tree[root].l == tree[root].r)
    {
        tree[root].val = sqrt(tree[root].val);
        return ;
    }
    int mid = (tree[root].l + tree[root].r) >> 1;
    if(l <= mid)
        update(l , r , root*2);
    if(r > mid)
        update(l , r , root*2+1);
    tree[root].val = tree[root*2].val + tree[root*2+1].val ;
}

void getsum(int l , int r , int root)
{
    if(tree[root].l >= l && tree[root].r <= r)
    {
        sum += tree[root].val ;
        return ;
    }
    int mid = (tree[root].l + tree[root].r) >> 1 ;
    if(l <= mid)
        getsum(l , r , root*2);
    if(r > mid)
        getsum(l , r , root*2+1);
    
}

int main()
{
    int n , m;
    int cnt = 0 ;
    while(~scanf("%d" , &n))
    {
        printf("Case #%d:\n" , ++cnt);
        build(1 , n , 1);
        scanf("%d" , &m);
        for(int i = 0 ; i < m ; i++)
        {
            int is , l , r ;
            scanf("%d%d%d" , &is , &l , &r);
            if(l > r) swap(l , r);//注意坑
            if(is == 0)
            {
                update(l , r , 1);
            }
            else
            {
                sum = 0 ;
                getsum(l , r , 1);
                printf("%lld\n" , sum);
            }
        }
        cout << endl ;
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/nonames/p/11606307.html