Ants POJ1852很有意思的一道题目

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output
4 8
38 207

题意: 在x坐标系上有一些蚂蚁, 每次移动一格, 方向由你来指定, 求出所有蚂蚁(即最后一个蚂蚁)下落的最短和最长时间.
这是白书上的一道贪心例题, 遇见这种题不要慌, 先分类讨论一下, 仔细思考每个状态的性质, 无外乎以下三种.
1.始终没有碰撞, 直接向最近的一端移动
2.发生碰撞, 然后反向移动
仔细思考, 不存在多次碰撞(因为速度相同), 而碰撞的话其实对两只蚂蚁的路径长度没有任何影响(视为交换即可), 由此可以推得, 最快的方案不过就是直接走向最近的一端

//POJ1852有意思的一道题目 
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
	int t;
	cin>>t;
	while(t--){
		int L,n,a[1000010];
		scanf("%d%d",&L,&n);
		for(int i=0;i<n;i++)
			cin>>a[i];
		//计算最短时间和最长时间
		int minT=0,maxT=0;
		for(int i=0;i<n;i++){
			minT=max(minT,min(a[i],L-a[i]));
			maxT=max(maxT,max(a[i],L-a[i]));
		}
		cout<<minT<<" "<<maxT<<endl;
	} 
} 
/*Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output
4 8
38 207
*/
发布了73 篇原创文章 · 获赞 27 · 访问量 1249

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103786761