1054.求平均值 (20分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

#include<iostream>
#include<string>

using namespace std;

bool isRealNumber(string &str)
{
    int dot=0;//小数点个数
    int f=0;//小数位数
    int i=0;
    bool flag=false;
    if(str[i]=='-')
        i++;
    for(;i<str.size();i++)
    {
        if(!isdigit(str[i])&& str[i]!='.')
        {
            return false;
        }
        
        if(str[i]=='.')
        {
            dot++;
            flag=true;
            continue;//为'.'flag不加1 
            
        }
        
		if(flag)
            f++;
    }

    if(dot>1 || f>2 || stod(str)>1000 ||stod(str)<-1000)
        return false;
    else
        return true;
}


int main(){
    int n,k=0;
    double sum=0;
    cin>>n;
    string s;
    for(int i=0;i<n;i++)
    {
        cin>>s;
        if(isRealNumber(s))
        {
           k++;
           sum+=stod(s);

        }
        else
        {
            //printf("ERROR: %s is not a legal number\n",s.c_str());//string字符串转为正规C字符串 
            cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
        }
    }
        
    if(k==0)
        printf("The average of 0 numbers is Undefined\n");
    else if(k==1)
        printf("The average of %d number is %0.2lf",k,sum/k);
    else
        printf("The average of %d numbers is %0.2lf",k,sum/k);
    
    return 0;
}
发布了276 篇原创文章 · 获赞 30 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_42905141/article/details/104023464