PAT 乙级 1054 求平均值 (20分)

1054 求平均值 (20分)
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:

2
aaa -9999
输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
int main(){
    int n,num;
    double sum;
    string temp;
    sum = num =0;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        double mid = atof(temp.c_str());
        bool flag = false;
        int cnt_dot = 0;
        int first_dot = temp.length () - 1;
        if(isdigit(temp[0]) || temp[0] == '.' || temp[0] == '-'){
            for (int j = 0; j < temp.length(); ++j) {
                if(temp[j] == '.'){
                    cnt_dot++;
                    if(cnt_dot == 1)
                        first_dot = j;
                }
            }
            if(cnt_dot <= 1 && temp.length()-1 - first_dot <=2 && mid <= 1000 && mid >= -1000)
                flag = true;
        }
        if(flag){
            num++;
            sum += mid;
        }else
            cout<<"ERROR: "<<temp<<" is not a legal number"<<endl;
    }
    if(num == 0){
        cout<<"The average of 0 numbers is Undefined";
    } else{
        if(num == 1){
            cout<<"The average of 1 number is ";
        } else
            cout<<"The average of "<<num<<" numbers is ";
        printf("%.2f\n",double(sum)/num);
    }
    return 0;
}
发布了139 篇原创文章 · 获赞 67 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43422111/article/details/104149230