PAT乙级刷题之路1054 求平均值 (20分)

1054 求平均值 (20分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:
2
aaa -9999

输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

#include <iostream>
#include <string>
#include <vector>
using namespace std;

int main()
{
	int N;
	cin>>N;
	string s;
	double sum; //合法数据的和 
	int i,j,K=0;//K记录合法输入个数 
	for(i=0;i<N;i++){
		cin>>s;
		int count1=0,count2=0;//记录负号和'.'的个数 
		int flag=1;//记录输入是否合法 
		//首先要对第一个字符进行判断只能是负号或数字
		if(s[0]=='-'){ 
			count1++;
		}else if(s[0]>='0'&&s[0]<='9'){
		}else{
			printf("ERROR: %s is not a legal number\n",s.c_str());
			continue; 
		}
		//如果第一个字符合法进行下面的判断:一个“合法”的输入是 [-1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。 
		for(j=1;j<s.length();j++){
			if(s[j]>='0'&&s[j]<='9'){				
			}else if(s[j]=='.'){
				count2++;
				int len=s.length()-j-1;//记录小数点后位数 
				if(count2>1||len>2){
					flag=0; 
					break;
				}
			}else if(s[j]=='-'){
				count1++;
				if(count2>1){
					flag=0; 
					break;
				}
			}else{
				flag=0; 
				break;
			}
		}		
		if(flag==1){
			if(stod(s)>=-1000&&stod(s)<=1000){
				sum+=stod(s); 
				K++;
			}else{
				flag=0;
			}
		}
		if(flag==0){
			printf("ERROR: %s is not a legal number\n",s.c_str());
		}
	}
	if(K==0){
		printf("The average of 0 numbers is Undefined");
	}else if(K==1){
		printf("The average of 1 number is %.2f",sum);
	}else{
		printf("The average of %d numbers is %.2f",K,sum/K);
	}
	return 0;
}
发布了73 篇原创文章 · 获赞 0 · 访问量 535

猜你喜欢

转载自blog.csdn.net/derbi123123/article/details/103793430