HDU 2756 Unique Snowflakes

容器的使用

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2756

Problem Description
Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold.

The marketing motto for the company is "bags of uniqueness." To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed.
 

Input
The first line of each test chunk contains an integer specifying the number of test cases in this chunk to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine. The following n lines each contain an integer (in the range 0 to 10^9, inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical. The input will contain no more than one million total snowflakes.
Please process to the end of the data file.
 

Output
For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.
 

Sample Input
 
  
1 5 1 2 3 2 1 1 5 1 2 3 2 1
 

Sample Output
 
  
3 3

题目大意:输入长度为n(n<=10^6)的序列,找出最长的子序列使得其中没有相同的元素。

采用stl的set容器,从l=0开始,r不断往右延伸,直到出现了相同的元素,此时,应该把l向右延伸一位,再让r继续往右延伸,如此反复直到序列的末端。每一次让l向右移动时就是得到子序列的最大长度的时候,分别比较这些长度即可得出最大长度。

代码如下:

#include<iostream>
#include<set>
#include<algorithm>
using namespace std;

int max(int a,int b){
	return a>b?a:b;
}
const int maxn=1000005;
int a[maxn];

int main()
{
//	freopen("E:\\in.txt","r",stdin);
	int T;
	while(cin>>T){
		while(T--){
			int n,i;
			cin>>n;
			for(i=0;i<n;i++)
				cin>>a[i];
			set<int> s;		//集合
			int l=0,r=0,ans=0;
			while(r<n){
				while(r<n&&!s.count(a[r]))//a[r]在s里还没出现过
					s.insert(a[r++]);	
				ans=max(ans,r-l);	//得到当前最长的长度,并与ans比较
				s.erase(a[l++]);//l往前移,即删除左端的元素
			}
			cout<<ans<<endl;
		}
	}
	return 0;
}


发布了54 篇原创文章 · 获赞 62 · 访问量 10万+

猜你喜欢

转载自blog.csdn.net/u013053268/article/details/48354409