第三十八题 UVA11572 唯一的雪花 Unique Snowflakes

PDF
Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a
machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow,
one by one, into a package. Once the package is full, it is closed and shipped to be sold.
The marketing motto for the company is “bags of uniqueness.” To live up to the motto, every
snowflake in a package must be different from the others. Unfortunately, this is easier said than done,
because in reality, many of the snowflakes flowing through the machine are identical. Emily would like
to know the size of the largest possible package of unique snowflakes that can be created. The machine
can start filling the package at any time, but once it starts, all snowflakes flowing from the machine
must go into the package until the package is completed and sealed. The package can be completed
and sealed before all of the snowflakes have flowed out of the machine.
Input
The first line of input contains one integer specifying the number of test cases to follow. Each test
case begins with a line containing an integer n, the number of snowflakes processed by the machine.
The following n lines each contain an integer (in the range 0 to 109
, inclusive) uniquely identifying a
snowflake. Two snowflakes are identified by the same integer if and only if they are identical.
The input will contain no more than one million total snowflakes.
Output
For each test case output a line containing single integer, the maximum number of unique snowflakes
that can be in a package.
Sample Input
1
5
1
2
3
2
1
Sample Output
3

题目大意:

对于每组数据,在1-n的序列中,找出一个最长的序列,使得该子序列中没有重复的元素

八年前的滑动窗口

// UVa 11572 唯一的雪花
#include<cstdio>
#include<cstring>
#include<iostream>
#include<set>
#include<algorithm>
#define Maxn 1000005

using namespace std;

int A[Maxn];

int main() {
	int T,n; scanf("%d",&T);
	while(T--) {
		scanf("%d",&n);
		for(int i=0; i<n; i++) scanf("%d",&A[i]);
		set<int> s;
		int L = 0, R = 0, Ans = 0;
		while(R < n) {
			while(R < n && !s.count(A[R])) s.insert(A[R++]);
			Ans = max(Ans , R - L);
			s.erase(A[L ++]);
		}
		printf("%d\n",Ans);
	}
}
发布了732 篇原创文章 · 获赞 31 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/qq_35776409/article/details/103964304