POJ NO.2386

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

  • Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.
Sample Output

3

读题费了很大的功夫,不知道什么是八连通。题意为一滩积水W 和 与其八连通(类似于扫雷中一个数字周围的八个格子)的积水视位同一片。求一共有多少个水洼(只要有一滩积水便可视为一个水洼) 做法为将每一摊积水和与其连通的积水消去(直到没有与之连通的积水) 视为一个水洼。

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int MAX_SIZE = 100;

int N, M;
char field[MAX_SIZE][MAX_SIZE + 1];

void dfs(int row, int col)
{
	field[row][col] = '.';
	for (int i = -1; i <= 1; i++){
		for (int j = -1;  j <= 1; j++){
			int tmp_row = row + i, tmp_col = col + j;
			if (tmp_row >= 0 && tmp_row < N && tmp_col >= 0 && tmp_col < M &&
			    field[tmp_row][tmp_col] == 'W'){
				dfs(tmp_row, tmp_col);
			}
		}
	}
}

int main()
{
	cin >> N >> M;
	for (int i = 0; i < N; i++){
		for (int j = 0; j < M; j++){
			cin >> field[i][j];
		}
	}

	int res = 0;
	for (int i = 0; i < N; i++){
		for (int j = 0; j < M; j++){
		    if (field[i][j] == 'W'){
				dfs(i, j);
				res++;
			}
		}
	}
	cout << res << endl;
}
发布了24 篇原创文章 · 获赞 0 · 访问量 376

猜你喜欢

转载自blog.csdn.net/weixin_43971049/article/details/103566674