杭电OJ——2005 第几天?

杭电OJ——2005 第几天?

谨以此文记录我的菜鸟敲代码之路

真的想提高编程能力,最近在刷杭电的第11页OJ,八说了,上我的菜鸟代码。

第几天?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 251887 Accepted Submission(s): 87013

Problem Description
给定一个日期,输出这个日期是该年的第几天。

Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。

Sample Input
1985/1/20
2006/3/12

Sample Output
20
71

#include <iostream>

using namespace std;

bool judge_run(int year) {
	//闰年2月29天,平年28天 
	//闰年条件:1、能被4整除且不能被100整除 
	//2、能被400整除 
	if ( year%4 == 0 && year%100 != 0) {
		return true; 
	} 
	if ( year%400 == 0) {
		return true; 
	} 
	return false;
}

int main() {
	int d[] = {31,0,31,30,31,30,31,31,30,31,30,31}; //2月暂定为0 
	int year,month,day;
	char a,b;
	
	while ( scanf("%d%c%d%c%d", &year,&a,&month,&b,&day) != EOF) {
		int sum = 0;
		if( judge_run(year) ) d[1] = 29;
		else d[1] = 28;
		sum += day;
		for (int i = month - 1; i >= 1; i-- ) {
			sum += d[i - 1];
		} 
		cout << sum << endl;
	}
	
	return 0;
}
发布了2 篇原创文章 · 获赞 0 · 访问量 18

猜你喜欢

转载自blog.csdn.net/qq_44296342/article/details/104089786