PAT甲级1072

1072 Gas Station (30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution
#include<bits/stdc++.h>
using namespace std;

const int Max = 1020;
const int inf = 0x3fffffff;
int n, m, k, ds;
double g[Max][Max], num[Max], d[Max];
bool visit[Max];

void Dijkstra(int s){
	fill(visit, visit + Max, false);
	fill(d, d + Max, inf);
	d[s] = 0;
	for(int i = 1; i <= n + m; i++){
		int u = -1, min = inf;
		for(int j = 1; j <= n + m; j++){
			if(!visit[j] && d[j] < min){
				min = d[j];
				u = j;
			}
		}
		if(u == -1)
			return;
		visit[u] = true;
		for(int v = 1; v <= n + m; v++){
			if(!visit[v] && g[u][v] != inf){
				if(d[u] + g[u][v] < d[v]){
					d[v] = d[u] + g[u][v];
				}
			}
		}
	}
}

int getid(string str){
	int ans = 0;
	if(str[0] != 'G'){
		for(int i = 0; i < str.size(); i++)
			ans = ans * 10 + str[i] - '0';
		return ans;
	}
	else{
		for(int i = 1; i < str.size(); i++)
			ans = ans * 10 + str[i] - '0';
		return ans + n;
	}
}

int main(){
	fill(g[0], g[0] + Max * Max, inf);
	scanf("%d %d %d %d", &n, &m, &k, &ds);
	string a, b;
	double c;
	for(int i = 0; i < k; i++){
		cin >> a >> b >>c;
		int h1 = getid(a);
		int h2 = getid(b);
		g[h1][h2] = g[h2][h1] = c;
	}
	int ans;
	double dis = -1, avg;
	for(int i = n + 1; i <= n + m; i++){
		Dijkstra(i);
		double tempmax = -1, tempmin = inf, sum = 0;
		for(int j = 1; j <= n; j++){
			if(d[j] > tempmax)
				tempmax = d[j];
			if(d[j] < tempmin)
				tempmin = d[j];
			sum += d[j];
		}
		if(tempmax > ds)
			continue;
		if(tempmin > dis){
			dis = tempmin;
			avg = sum / n;
			ans = i;
		}
		else if(tempmin == dis){
			if(sum / n < avg){
				avg = sum / n;
				ans = i;
			}
		}
	}
	if(dis == -1)
		printf("No Solution");
	else{
		printf("G%d\n", ans - n);
		printf("%.1lf %.1lf", dis, avg);
	}
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6026

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86935579