【简单】Divisor Summation

描述

Give a natural number n (1 <= n <= 500000), please tell the summation of all its proper divisors.

Definition: A proper divisor of a natural number is the divisor that is strictly less than the number.

e.g. number 20 has 5 proper divisors: 1, 2, 4, 5, 10, and the divisor summation is: 1 + 2 + 4 + 5 + 10 = 22.

输入

An integer stating the number of test cases, and that many lines follow each containing one integer between 1 and 500000.

输出

One integer each line: the divisor summation of the integer given respectively.

样例输入

3
2
10
20

样例输出

1
8
22

题目来源

ZOJ Monthly 2004.3
分析:
求约数之和。
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
cin>>n;
while(n–)
{
int m;
cin>>m;
int ans=0;
for (int i=1;i<m;i++)
{
if (m%i==0) ans+=i;
}
cout<<ans<<endl;
}
return 0;
}

发布了122 篇原创文章 · 获赞 0 · 访问量 4675

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104136857