快速幂——Easy Summation

HDU 6027

Easy Summation

Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k. Let f(i)=ik, please evaluate the sum f(1)+f(2)+…+f(n). The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.

Input
The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
Each of the following T lines contains two integers n(1≤n≤10000) and k(0≤k≤5).

Output
For each test case, print a single line containing an integer modulo 109+7.

Sample Input
3
2 5
4 2
4 1

Sample Output
33
30
10

就是给出一个n,和指数
1到n 分别求指数次幂,相加求和
自己错误原因:数据类型

不用快速幂也可
这里幂最大才是5

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <math.h>
using namespace std;
typedef unsigned long long ll;
ll mod = 1e9+7;
ll quick(ll a, int b){
    ll ans = 1;
    while(b){
        if(b&1)
            ans = ans * a % mod;
        a = a * a % mod;
        b >>= 1;
    }
    return ans;
}

int main(){
    int n;
    int a,b;
    scanf("%d",&n);
    while(n--){
        scanf("%d %d",&a,&b);
        ll sum = 1;
        for(int i=2; i<=a; i++)
            sum = (sum + quick(i,b) + mod ) % mod;
        printf("%lld\n",sum);
    }
    return 0;
}
//虽然输入的是int范围内,但是在快速幂的运算中 a = a * a % mod;
//可以仅quick a为ll

发布了30 篇原创文章 · 获赞 0 · 访问量 672

猜你喜欢

转载自blog.csdn.net/jhckii/article/details/104162573