杭电oj 1003

杭州电子科技大学 online judge 1003 题

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
//注意此处有空格
Case 2:
7 1 6
Author
Ignatius.L

个人思路:
1.确定输入的case,用变量t表示
2.确定序列的长度,用n表示
3.灵活分配内存空间,并且依次输入序列
4.确定子序列起始位置p1:p1>=1;
确定子序列末尾位置p2:顺序加和最大时的j
5.输出:注意输出多一行空格

代码

#include<iostream>
using namespace std;
int main()
{
 int t,n;//执行情况(case)次数: t  每种情况输入数据个数:n   
 cin>>t;
 for(int i = 1;i<=t;i++){  
     int i1 = 0, sum = 0;//max为最大子序列和 
     int p1 =0,p2 = 0;//p1:起始位置 p2:末尾位置 
     cin>>n;
     int* seq = new  int[n];//灵活分配内存 
  for(int j = 0;j<n;j++){
      cin>>seq[j];
  }
     int max = seq[0];
  for(int j = 0;j<n;j++){
     sum = sum + seq[j];//顺序加和,逐次判断 
    if(sum>max){
    max = sum;
    p1 = i1;
    p2 = j;  
   }
   if(sum<0)
   { 
     sum = 0;
     i1 = j + 1;
   }
  }
  cout << "Case " << i << ":" << endl;
  if(i<t) cout<<max<<" "<<p1+1<<" "<<p2+1<<endl<<endl;
  else  cout<<max<<" "<<p1+1<<" "<<p2+1<<endl; 
  delete[] seq;//释放内存 
 } 
 return 0;
}
发布了5 篇原创文章 · 获赞 0 · 访问量 66

猜你喜欢

转载自blog.csdn.net/MARSHCW/article/details/104224950