PAT A1046 1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105​​]), followed by N integer distances D1D2⋯DN, where D​i is the distance between the i-th and the (i+1)-st exits, and D​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题意:

求点到点之间的最短路径;

输入格式:

节点数N,两节点之间的距离D[i](i到i+1之间的距离)
测试数目
节点1 节点2
节点1 节点2
… …

输出格式:

测试点1的最短距离
测试点2的最短距离

思路:

(1)开一个数组dis,dis[i]存放节点1到节点i+1的距离,sum表示所有节点之间的路径总和;
(2)节点left到节点right的最短距离为dis[right-1]-dis[left-1]与sum-(dis[right-1]-dis[left-1])之间的最小值;

代码:

#include <cstdio>
#include <algorithm>
using namespace std;
int main(){
	int N;
	scanf("%d",&N);
	int D[N+1],sum=0,dis[N+1];
	dis[0]={0};
	for(int i=1;i<=N;i++){
		scanf("%d",&D[i]); 
		sum+=D[i];
		dis[i]=sum;//dis[i]存放1到i+1的距离
	} 
	int M;
	scanf("%d",&M);
	int left,right,dis_result;
	for(int i=0;i<M;i++){
		scanf("%d %d",&left,&right);
		if(left>right){
			int temp=left;
			left=right;
			right=temp;
		}
		dis_result=dis[right-1]-dis[left-1];
		dis_result=min(dis_result,sum-dis_result);
		printf("%d\n",dis_result);
		dis_result=0;
	}
	return 0;
}

词汇:

a positive integer 一个正整数
corresponding 相应的

发布了26 篇原创文章 · 获赞 0 · 访问量 495

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/101875576