PAT-A 1046. Shortest Distance (20)(20 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805435700199424

1046 Shortest Distance (20)(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

思路

这题思路还是蛮重要的,设计一个dis【】数组记录表示点1到点i的距离,因为题目要求点u到点v的最短距离:

分两种情况:

1、求dis(u,v)就是dis[v-1]-dis[u-1];

2、因为路径本身是个环,另有:sum-dis(u,v)

求这两种情况的最小值

#include <iostream>
#include<cstdio>
#include<algorithm> 
using namespace std;
const int nmax=1e5+1;
const int mmax=1e4;
int a[nmax];  //a[i]表示点第i条边,点i到点i+1的距离
int dis[nmax];//dis[i]表示点1到点i的距离 

int main(int argc, char** argv) {
	int n;
	cin>>n;
	int sum=0;
	for(int i=1;i<=n;i++){
		cin>>a[i];
		sum+=a[i];
		dis[i]=sum;
	}
	int m;
	cin>>m;
	int u,v;
	int dist;
	for(int i=0;i<m;i++){
		cin>>u>>v;
		if(u>v){
			swap(u,v);
		}
		int tmp=dis[v-1]-dis[u-1];
		int ans=min(tmp,sum-tmp);
		cout<<ans<<endl;
			
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81158524