1046. Shortest Distance (20)(C++)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3 10 7

题目大意:有一个圈,求一点a到另一点b最短距离,即求ab之间哪边的半圆更短。

解题思路:每一点不直接存该点到下一点的距离,而是从1到该点的总距离(思想类似1044的shopping in Mars),这样就避免了每次都要加。

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;
int main(){
	std::vector<int> v;
	int sum=0;
	int n;
	cin>>n;
	v.resize(n+1);
	v[0]=0;
	for(int i=1;i<=n;++i){
		scanf("%d",&v[i]);
		sum+=v[i];
		v[i]=sum;
	}
	int m;
	cin>>m;
	for(int k=0;k<m;++k){
		int i,j,dis=0;
		scanf("%d %d",&i,&j);
		if(i>j)
			swap(i,j);
		dis=v[j-1]-v[i-1];
		dis=min(dis,sum-dis);
		cout<<dis<<'\n';
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/80152969