UVA701 LA5637 The Archeologists' Dilemma

An archeologist seeking proof of the presence of extraterrestrials in the Earth’s past, stumbles upon a
partially destroyed wall containing strange chains of numbers. The left-hand part of these lines of digits
is always intact, but unfortunately the right-hand one is often lost by erosion of the stone. However,
she notices that all the numbers with all its digits intact are powers of 2, so that the hypothesis that
all of them are powers of 2 is obvious. To reinforce her belief, she selects a list of numbers on which it
is apparent that the number of legible digits is strictly smaller than the number of lost ones, and asks
you to find the smallest power of 2 (if any) whose first digits coincide with those of the list.
Thus you must write a program such that given an integer, it determines (if it exists) the smallest
exponent E such that the first digits of 2
E coincide with the integer (remember that more than half of
the digits are missing).
Input
It is a set of lines with a positive integer N not bigger than 2147483648 in each of them.
Output
For every one of these integers a line containing the smallest positive integer E such that the first digits
of 2
E are precisely the digits of N, or, if there is no one, the sentence ‘no power of 2’.
Sample Input
1
2
10
Sample Output
7
8
20

题意:一个数字是2的次幂,但他的后几位被擦去了,擦去的比保留的位数多,现给出前几位,问他原来的数最小是多少

思路:
因为N*10^ n<28 ^ m<(N + 1)*10^n
所以log2 N +n * log2 10<m < log2(N +1)+n * log2 l0,(n>floot(lgN )+1)
枚举n直到floot(log2 N +n * log2 10)<floot( log2(N +1)+n * log2 10 )为止

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
#define ll long long
int main()
{
    ll n;
    while(~scanf("%lld",&n))
    {
        int m=0;
        int t=n;
        while(t)
        {
            m++;
            t/=10;
        }
        for(int i=m+1;;i++)
        {
             int a=(ll)(log2(n)+i*log2(10));
             int b=(ll)(log2(n+1)+i*log2(10));
             if(a!=b)
             {
                 printf("%d\n",b);
                 break;
             }
        }
    }
}

发布了261 篇原创文章 · 获赞 14 · 访问量 7378

猜你喜欢

转载自blog.csdn.net/weixin_43244265/article/details/104264406
LA