HDU6441(费马大定理,勾股定理)

people in USSS love math very much, and there is a famous math problem .

give you two integers nn,aa,you are required to find 22 integers bb,cc such that anan+bn=cnbn=cn.
Input
one line contains one integer TT;(1≤T≤1000000)(1≤T≤1000000)

next TT lines contains two integers nn,aa;(0≤n≤1000(0≤n≤1000,000000,000,3≤a≤40000)000,3≤a≤40000)
Output
print two integers bb,cc if bb,cc exits;(1≤b,c≤1000(1≤b,c≤1000,000000,000)000);

else print two integers -1 -1 instead.
Sample Input
1
2 3
Sample Output
4 5

题意:给你两个数你,a,n求两个数b,c满足 a^n + b^n= c^n.

思路:
费马大定理:当整数n>2时,关于的方程 a^n + b^n= c^n没有正整数解。
因此我们只讨论n<=2的情况(n=0,n=1,n=2)
当n=2时,满足勾股定理
勾股定理的一个规律:n为奇数有勾股数(2n+1,2nn+2n,nn+1);n为偶数有勾股数(2n,nn-1,nn+1)

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long int
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll a,n;
        scanf("%lld%lld",&n,&a);
        if(n>2||n==0)
        {
            printf("-1 -1\n");
        }
        if(n==1)
        {
             printf("1 %lld",a+1);
        }
        if(n==2)
        {
            if(a%2)
            {
                ll x=(a-1)/2;
                ll b=2*x*x+2*x;
                ll c=2*x*x+2*x+1;
                printf("%lld %lld\n",b,c);
            }
            else
            {
                ll x = a/2;
                ll b=x*x-1;
                ll c=x*x+1;
                printf("%lld %lld\n",b,c);
            }
        }
    }
}
发布了261 篇原创文章 · 获赞 14 · 访问量 7417

猜你喜欢

转载自blog.csdn.net/weixin_43244265/article/details/104057081