HDU 1260 动态规划

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13794    Accepted Submission(s): 6774


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 
Sample Input
2 2 20 25 40 1 8
 
Sample Output
08:00:40 am 08:00:08 am
 
AC代码
#include<iostream>
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
#include<cstring>
typedef long long ll;
using namespace std;
int a[2005],ans,b[2005],dp[2005],k,n;
int main(){
    cin>>n;
    while(n--){
        cin>>k;
        dp[0]=0;
        for(int i=1;i<=k;++i)scanf("%d",&a[i]);
        for(int i=2;i<=k;++i)scanf("%d",&b[i]);
        dp[1]=a[1];
        for(int i=2;i<=k;++i)dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]); 
        ans=dp[k];
        int h=ans/3600+8;int m=(ans-(h-8)*3600)/60;int s=(ans-(h-8)*3600)%60;
        if(h<12)
        printf("%02d:%02d:%02d am\n",h,m,s);
        else
        printf("%02d:%02d:%02d pm\n",h%12,m,s);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/m2364532/p/12402367.html