PAT 乙级 1064 朋友数 (20分)

1064 朋友数 (20分)

如果两个整数各位数字的和是一样的,则被称为是“朋友数”,而那个公共的和就是它们的“朋友证号”。例如 123 和 51 就是朋友数,因为 1+2+3 = 5+1 = 6,而 6 就是它们的朋友证号。给定一些整数,要求你统计一下它们中有多少个不同的朋友证号。
输入格式:

输入第一行给出正整数 N。随后一行给出 N 个正整数,数字间以空格分隔。题目保证所有数字小于 104。
输出格式:

首先第一行输出给定数字中不同的朋友证号的个数;随后一行按递增顺序输出这些朋友证号,数字间隔一个空格,且行末不得有多余空格。
输入样例:

8
123 899 51 998 27 33 36 12
输出样例:

4
3 6 9 26
作者: CHEN, Yue
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB
代码长度限制: 16 KB

#include <iostream>
#include <set>
#include <iterator>
using namespace std;
int main(){
    int n,input,mid;
    set<int> ans;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>input;
        mid = 0;
        while(input){
            mid += input % 10;
            input /= 10;
        }
        ans.insert(mid);
    }
    cout<<ans.size()<<endl;
    for(set<int>::iterator it = ans.begin(); it != ans.end();it++){
        if(it != ans.begin())
            cout<<" ";
        cout<<*it;
    }
    return 0;
}
发布了130 篇原创文章 · 获赞 57 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43422111/article/details/104472368
今日推荐