【PAT - 甲级1009】Product of Polynomials (25分)(模拟,细节)

题干:

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

 题目大意:

按照输入的格式 给定两个多项式A和B,让你按照相同的格式输出两个多项式的乘积,也就是A×B。

解题报告:

就是个模拟题,但是注意细节不少。

1.首先观察输入可以发现当系数为0的时候这一项是需要省略的。

2.其次最后输出的第一个数不是最高次项,而是后面需要跟着的数的个数。

3.次数需要从高往低输出。

4.注意进行多项式乘积的时候,跟输入的两个K是没有关系的,而是跟两组N1...Nk是有关系的,又因为这里保证了N是由大到小的,也就是只和两个N1是有关系的。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
double A[MAX],B[MAX],C[MAX],b;
int n,m,mx,a;
int main()
{
	cin>>n;
	for(int i = 1; i<=n; i++) {
		scanf("%d%lf",&a,&b);
		A[a] = b;
		if(i == 1) mx = a;
	}
	cin>>m;
	for(int i = 1; i<=m; i++) {
		scanf("%d%lf",&a,&b);
		B[a] = b;
		if(i == 1) mx += a;
	}
	for(int i = 0; i<=mx; i++) {
		for(int j = 0; j<=mx; j++) {
			C[i+j] += A[i]*B[j];
		}
	}
	int ans = 0;
	for(int i = 0; i<=mx; i++) {
		if(C[i] != 0) ans++;
	}
	printf("%d",ans);
	for(int i = mx; i>=0; i--) {
		if(C[i] == 0) continue;
		printf(" %d %.1f",i,C[i]);
	}
	return 0 ;
}
发布了1106 篇原创文章 · 获赞 122 · 访问量 23万+

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/104169543