Problem F: F. Distribution

Problem F: F. Distribution

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 10   Solved: 9
[ Submit][ Status][ Web Board]

Description


One day , Wang and Dong in the Dubai desert expedition, discovered an ancient castle. Fortunately, they found a map of the castle.The map marks the location of treasures.

They agreed to distribute the treasures according to the following rules:

Wang draws a horizontal line on the map and then Dong draws a vertical one so that the map is divided into 4 parts, as show below.    

图

Wang will save the treasures in I and III ,while those situated in II and IV will be taken away by Dong. Wang first draw a horizontal line, Dong after the draw a vertical line.

They drew several pairs of  lines. For each pair, Wang wants to know the difference between their treasures.

It's guaranteed that all the reasures will lie on neither of the lines drew by them.

Input

the first line contains two integers N and M, where N is the number of treasures on the map and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines Xi, Yi contain the co-ordinates of the treasures and the last M lines consist of the M pairs integers (X, Y) which means that the two splitting lines intersect at point (X, Y).

(  0 < NM ≤ 100,  0 ≤ Xi, Yi, X,Y ≤ 1000  )

Output

Output  contains  M  lines , a single line with a integer , the difference described above.

扫描二维码关注公众号,回复: 1066795 查看本文章

Sample Input

10 3
29 22
17 14
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24

Sample Output

-6
4
4
代码如下:
#include<iostream>
using namespace std;
int main()
{
	int N, M;
	cin >> N >> M;

	int X[100], Y[100];
	for (int i = 0; i < N; i++)
		cin >> X[i] >> Y[i];

	while (M--)
	{
		int x, y, sum = 0;
		cin >> x >> y;
		for (int j = 0; j < N; j++)
		{
			if (((x - X[j]) > 0 && (y - Y[j]) > 0) || ((x - X[j]) < 0 && (y - Y[j]) < 0))
				sum++;
		}

		cout << 2 * sum - N << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/TOBEALISTENNER/article/details/80384561