Problem F. Grab The Tree

Problem F. Grab The Tree

题目:

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 135    Accepted Submission(s): 97

http://acm.hdu.edu.cn/showproblem.php?pid=6324

Problem Description
Little Q and Little T are playing a game on a tree. There are  n vertices on the tree, labeled by 1,2,...,n, connected by n1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.
 
Input
The first line of the input contains an integer  T(1T20), denoting the number of test cases.
In each test case, there is one integer n(1n100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1wi109), denoting the value of each vertex.
For the next n1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.
 
Output
For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.
 
Sample Input
1 3 2 2 2 1 2 1 3
 
Sample Output
Q
 
Source

题意:

      给定一棵n 个点的树,每个点有权值。两个人玩游戏,先手需要占领若干不相邻的点,然后后手占领剩下所有点。每个人的得分为占领的点权异或和,分高的获胜。问最优策略下游戏的结果。

思路:

  设sum 为所有点权的异或和,A 为先手得分,B 为后手得分。若sum = 0,则A = B,故无论如何都是平局。否则考虑sum 二进制下最高的1 所在那位,一定有奇数个点那一位为1。若先手拿走任意一个那一位为1 的点,则B 该位为0,故先手必胜。

代码:

#include<cstdio>
#include<vector>
using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int xorSum=0;
        for(int i=1;i<=n;i++){
            int v;
            scanf("%d",&v);
            xorSum^=v;
        }
        for(int i=1;i<=n-1;i++){
            int u,v;
            scanf("%d%d",&u,&v);
        }
        if(xorSum==0)puts("D");
        else puts("Q");

    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/longl/p/9392760.html