矩形着色(CSU)

Description

Danni想为屏幕上的一个矩形着色,但是她想到了一个问题。当点击鼠标以后电脑是如何判断填充的区域呢?

现在给你一个平面直角坐标系,其中有一个矩形和一个点,矩形的四条边均是平行于x轴或y轴的。请你判断这个点相对于矩形的位置,即在矩形内,在矩形上,还是在矩形外?

Input

第一行只有一个整数T,(T < 150),代表共有T种情况。

接下对于每种情况,均有两行数据:

第一行有两个整数Px Py,以空格分隔,代表点的坐标(Px,Py).

第二行有四个整数Ax Ay Bx By,以空格分隔,代表矩形左下角的坐标(Ax,Ay)和右上角的坐标(Bx,By).

所有的坐标均为区间[0,100]内的整数,且Ax<Bx,Ay<By

Output

对于每种情况仅输出一行:

  1. 如果点在矩形外部,请输出”Outside”
  2. 如果点正好在矩形的边上,请输出”On”
  3. 如果点在矩形内部,请输出”Inside” 所有输出都不包含引号。

Sample Input

3
38 7
30 7 52 66
55 1
9 13 54 84
74 67
73 66 76 68

Sample Output

On
Outside
Inside

#include <iostream>
using namespace std;
int main() {
	int n, x, y;
	int x1, y1, x2, y2;
	cin>>n;
	while(n--) {
		cin>>x>>y;
		cin>>x1>>y1>>x2>>y2;
		if(x1<x && x<x2 && y1<y && y<y2) {
			cout<<"Inside"<<endl;
		} else if(((y==y1 || y==y2) && x1<=x && x<=x2)||
				(x==x1 || x==x2) && y1<=y && y<=y2) {
			cout<<"On"<<endl;
		} else {
			cout<<"Outside"<<endl;
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/adusts/article/details/80479890