HDU 1048 The Hardest Problem Ever

The Hardest Problem Ever

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29319    Accepted Submission(s): 13746

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".

 

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

 

Sample Input

START

NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX

END

START

N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ

END

START

IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ

END

ENDOFINPUT

 

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES

I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME

DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

 

Source

South Central USA 2002

 

 

解题思路:

通过输入STARTEND来控制输入字符,我的想法是用string类定义一个字符串数组,并在开始判断他是ENDOFINPUT还是START,并不用管END

不过要记住在输入START结束后你会按下回车。

也就是如果不利用getchar();,会导致你的字符串还没开始输入就已经向其中输入了一个结束符,这会让你后来输入的字符成为无用功。

然后注意需要变换的A~E,只用往后移21位,F~Z只用往前移5位。然后END只要在输出字符串前输入一下就好了。

以下是我的AC代码。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    char str[200];
    int len;
    string panduan;
    while(1)
    {
        memset(str, 0, 200);
        cin>>panduan;
        getchar();
        if(panduan[0] == 'S')
        {
            fgets(str, 200, stdin);
            len = strlen(str);
            for(int i = 0; i < len; i++)
            {
                if(str[i] >= 'A' && str[i] <= 'E')
                    str[i] += 21;
                else if(str[i] > 'E' && str[i] <= 'Z')
                    str[i] -= 5;
                else continue;
            }
            cin>>panduan;
            cout<<str;
        }
        else if(panduan[0] == 'E' && panduan[3] == 'O')
            break;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/songziqi98/article/details/79475734
今日推荐