单调栈 Bad Hair Day

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

=
= =
= - = Cows facing right -->
= = =
= - = = =
= = = = = =
1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5
一排牛,站成一排从左往右看,每头牛只能看见比它个头矮的牛,问所有牛最多能看见多少。
将问题转化为,一头牛在它的右边最多能被多少头牛能看见。使用单调栈·,单调递增。这样栈顶元素小于其他栈内元素。

#include<stdio.h>
#include<stack>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
    
    
    ll n,i,a,ans=0;
    stack<ll> s;
    scanf("%lld",&n);
    for(i=0;i<n;i++)
    {
    
    
        scanf("%lld",&a);
        while(s.size()!=0&&a>=s.top())//高度相同,同样看不见
        {
    
    
            s.pop();
        }
        ans+=s.size();
        s.push(a);
    }
    printf("%lld\n",ans);
}

猜你喜欢

转载自blog.csdn.net/m0_46312382/article/details/112954151