POJ 3250 Bad Hair Day (单调栈应用)

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5
#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<queue>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1e9+7
#define ll unsigned long long
#define MAX 1000000000
#define ms memset
const int maxn=80005;
using namespace std;

int n;
int cnt[maxn],l,r;///单调栈的结构
/*
题目大意:给定一个序列代表一排母牛的高度,
要求每个牛朝右能看到的牛的数量的和(只能看到比自己矮的)。

单调栈维护着递增序列,
对每个进来的数,其删除的数全部记录,
但不仅是要记录个数,实际上还要计数
该数对应的动态规划的值。
用结构体记录下标即可。

*/

struct node
{
    int id,h;
};
node s[maxn],sk[maxn];

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&s[i].h);
        s[i].id=i;
    }

    l=0,r=-1;
    for(int i=n;i>=1;i--)
    {
        int res=0,tp=0;
        while(r>=l&&s[i].h>sk[r].h)
        {
            tp++;
            res+=cnt[sk[r].id];
            r--;
        }
        cnt[i]=res+tp;
        sk[++r]=s[i];
    }

    ll ans=0;
    for(int i=1;i<=n;i++ )   ans+=cnt[i];
    printf("%lld\n",ans);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/81447918