1063 Set Similarity (25分)
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
题意为求给定集合的并集和交集,即公共元素的比例。注意要去重,并按查询输入求出对应两组的相同元素比例。可以利用set来求解。
参考代码:
#include <cstdio>
#include <set>
using namespace std;
const int N=52;
set<int> st[N];
void compare(int x,int y)
{
int total =st[y].size(); //注意是y的个数
int same=0;
for(set<int>::iterator it=st[x].begin();it!=st[x].end();++it) //迭代器写法
{
if(st[y].find(*it)!=st[y].end()) //利用查找函数查询是否有相同元素
same++;
else
total++; //不同元素个数
}
printf("%.1f%%\n",same*100.0/total); //输出比例
}
int main()
{
int n,k,m,v,s1,s2;
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;++i)
{
scanf("%d",&m);
for(int j=0;j<m;++j)
{
scanf("%d",&v);
st[i].insert(v);
}
}
scanf("%d",&k); //输入查询个数
for(int i=0;i<k;++i)
{
scanf("%d%d",&s1,&s2); //查询组
compare(s1,s2);
}
}
return 0;
}