问题描述:
We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
输入说明:
First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
输出说明:
For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
SAMPLE INPUT:
1
3 5
46
64448
74
go
in
night
might
gn
SAMPLEOUTPUT:
3
2
0
思路:
题目的意思就是九个数字分别代表不同的字母(对应关系在题目中有所说明,其实就是一个九键键盘)然后给我们一串数字,问我们这些数组能对应哪些字母的组合。做法是去建立一个字典树,令a~z对应的数字都表现出来,先输入数字组合,再输入字符数组(代表了单词,用tree函数处理,得到对应的数字,对应数字的value++)最后输出各项的value即可。
AC代码:
#include<bits/stdc++.h>
using namespace std;
string num[30030];
int n,m;
map<string,int>a;
char dictionary(char ch)
{
if(ch=='a'||ch=='b'||ch=='c')
{
return '2';
}
else if(ch=='d'||ch=='e'||ch=='f')
{
return '3';
}
else if(ch=='g'||ch=='h'||ch=='i')
{
return '4';
}
else if(ch=='j'||ch=='k'||ch=='l')
{
return '5';
}
else if(ch=='m'||ch=='n'||ch=='o')
{
return '6';
}
else if(ch=='p'||ch=='q'||ch=='r'||ch=='s')
{
return '7';
}
else if(ch=='t'||ch=='u'||ch=='v')
{
return '8';
}
else
{
return '9';
}
}
string tree(string s )
{
string tem="";
int len=s.length();
for( int i=0;i<len;i++)
{
tem+=dictionary(s[i]);
}
return tem;
}
int main()
{
int t,i,len;
string s;
cin>>t;
while(t--)
{
a.clear();
cin>>n>>m;
for(i=1;i<=n;i++)
{
cin>>num[i];
}
for(i=1;i<=m;i++)
{
cin>>s;
a[tree(s)]++;
}
for(int i=1;i<=n;i++)
{
cout<<a[num[i]]<<endl;
}
}
return 0;
}