HDU-4287(巧妙打表+map)

 We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below: 
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o     
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z 
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences? 

Input

  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this: 
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words. 

Output

  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line. 

Sample Input

1
3 5
46
64448
74
go
in
night
might
gn

Sample Output

3
2
0

题目大意就是给n个电话号码,再给m个字符串,按照手机打字的九宫格,看对应的数字和字符串有几个匹配

用到了巧妙的打表,把字符串转换为号码,再用map[号码]++,这样输出时很方便,根据题目数据范围不会溢出

#include <iostream>
#include <map>

using namespace std;

map<int ,int >mp;
int a[5005];
int phone[26]={2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,7,7,7,7,8,8,8,9,9,9,9};//巧妙的打表
int phone_num(string s)//把电话号码转化成对应的数字
{
    int sum=0;
    for(int i=0;i<s.size();i++)
    {
        sum=sum*10+phone[(s[i]-'a')];
    }
    return sum;
}
int main()
{
    int t,n,m,num;
    string s;
    cin>>t;
    while(t--)
    {
        mp.clear();
        cin>>n>>m;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int j=0;j<m;j++)
        {
            cin>>s;
            mp[phone_num(s)]++;
        }
        for(int i=0;i<n;i++)
            cout<<mp[a[i]]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40733911/article/details/81431497