#1029. Median【二路归并】

原题链接

Problem Description:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N N N ( ≤ 2 × 1 0 5 \leq 2\times 10^5 2×105) is the size of that sequence. Then N N N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

Problem Analysis:

二路归并,和 归并排序 思想一致。

Code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int N = 2e5 + 10;

int n, m;
int a[N], b[N], c[N * 2];

int main()
{
    
    
    scanf("%d", &n);
    for (int i = 0; i < n; i ++ ) scanf("%d", &a[i]);
    scanf("%d", &m);
    for (int i = 0; i < m; i ++ ) scanf("%d", &b[i]);
    
    int k = 0, i = 0, j = 0; // 新数组,a数组,b数组中的下标
    while (i < n && j < m)
        if (a[i] <= b[j]) c[k ++ ] = a[i ++ ];
        else c[k ++ ] = b[j ++ ];
    
    while (i < n) c[k ++ ] = a[i ++ ];
    while (j < m) c[k ++ ] = b[j ++ ];
    
    printf("%d\n", c[(n + m - 1) / 2]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121140710