hdu2710(素数筛选法)

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11145    Accepted Submission(s): 3541


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
 
  
4 36 38 40 42
 

Sample Output
 
  

38

解析:采用素数筛选法,记录每个数的最大素数因子。然后直接比较。

#include<bits/stdc++.h>
using namespace std;

int f[20005];
int n,x,cnt;

int main()
{
    memset(f,0,sizeof(f));
    f[1]=1;//题目里的1是素数,去掉就不对了
    for(int i=2; i<=20005; i++)
    {
        if(f[i]==0)
        {
            for(int j=i; j<=20005; j+=i)
                f[j]=i;
        }
    }
    while(~scanf("%d",&n))
    {
        int p,m=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(f[x]>m)
            {
                m=f[x];
                p=x;
            }
        }
        printf("%d\n",p);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/80633340
今日推荐