POJ 3080 Blue Jeans 暴力枚举子串+kmp

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20420   Accepted: 9049

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

暴力枚举子串+KMP即可

#include <cstdio>
#include <cstring>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
#include <queue>
#include <stack>
#include <set>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 65;
char str[15][MAX_N+5];
int Next[MAX_N],n,len;
bool kmp(const char *T, const char *P)
{
	int t = -1,j=0;
   	Next[0]= -1;
	int lenT = strlen(T), lenP = strlen(P);
	while (j < lenP - 1)
		if (t < 0 || P[t] == P[j]) t++, j++, Next[j] = (P[j] == P[t] ? Next[t] : t);
		else t = Next[t];

	int i = 0; j = 0;
	while (i < lenT && j < lenP)
		if (j < 0 || T[i] == P[j]) i++, j++;
		else j = Next[j];

	return j == lenP;
}
bool match(const char *Substr){
     for(int i = 1;i<n;++i) if(!kmp(str[i],Substr)) return false;
     return true;
}
int main(){
    int t ;
    scanf("%d",&t);
    char ans[MAX_N+5],tmp[MAX_N+5];
    while(t--){
        scanf("%d\n",&n);
        for(int i=0;i<n;i++){
			scanf("%s",str[i]);
        }
            int flag = 0;
            for(len = 60;len>0;--len){
                for(int pos = 0;pos<=60-len;pos++){
                    strncpy(tmp,str[0]+pos,len);
                    tmp[len] = '\0';
                    //dbg(tmp);
                    if(match(tmp) ) {
                        if(!flag||strcmp(tmp,ans)<0)
                        {
                            strcpy(ans,tmp);
                        }
                        flag = 1;
                    }
                }
                    if(flag) break;
        }
                //int len_ans = strlen(ans);
               // dbg(len);
                if(len<3) printf("no significant commonalities\n");
                else printf("%s\n",ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80993763