POJ 3080 Blue Jeans【KMP+暴力】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/88024833

题目:

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题目大意:

       寻找多个字符串中最长相同子串。

解题思路:

       用暴力遍历某个串中所有子串,用KMP查找在其余串中是否存在。 

PS: 输入挂与scanf不可兼得【猛男落泪】。

解题代码:

#include<cstdio>
#include<fstream>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
using namespace std;

string s[15];
int Next[65];

void getnext(string ss,int d){
    int k=-1;   Next[0]=-1;
    for(int i=1;i<d;i++){
        while(k>-1&&ss[k+1]!=ss[i])
            k=Next[k];
        if(ss[k+1]==ss[i]) k++;
        Next[i]=k;
    }
}
bool kmp(string s1,int d1,string s2,int d2){   //判断母串中是否存在子串
    int k=-1;
    for(int i=0;i<d1;i++){
        while(k>-1&&s2[k+1]!=s1[i])
            k=Next[k];
        if(s2[k+1]==s1[i])k++;
        if(k==d2-1)return 1;
    }
    return 0;
}
int main(){
    ios::sync_with_stdio(false);    //加速
    cin.tie(0);
    int t,n;
    cin>>t;
    while(t--){
        cin>>n;
        for(int i=0;i<n;i++) cin>>s[i]; //每组数据有n个字符串
        string ans="";
        for(int i=1;i<=s[0].size();i++){
        for(int j=0;j<=s[0].size()-i;j++){
            string op=s[0].substr(j,i);
            getnext(op,op.size());
            bool flag=0;
            for(int k=1;k<n;k++){
                if(!kmp(s[k],s[k].size(),op,op.size()))
                    flag=1;
            }
            if(!flag){
                if(ans.size()<op.size())
                    ans=op;
                else if(ans.size()==op.size())
                    ans=min(ans,op);
            }
        }
        }
        if(ans.size()<3)
            cout<<"no significant commonalities"<<endl;
        else cout<<ans<<endl;
    }
    return 0;
}

Prev

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/88024833