POJ-2352 Stars (树状数组)

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 52887   Accepted: 22777

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

借鉴:https://blog.csdn.net/caojiangxia/article/details/45331103

利用树状数组减少比较时间。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 32100
int tree[MAXN]; //记得memset
int lowbit(int x)
{
    return x&(-x);
}
void CreateTree(int x,int v)
{
    int i;
    for(i=x;i<=MAXN;i+=lowbit(i))
    {
        tree[i]+=v;
    }
    return;
}
int sum(int x)
{
    int i;
    int ans;
    for(i=x;i>0;i-=lowbit(i))
    {
        ans+=tree[i];
    }
    return ans;
}
int main()
{
  int n;
  int i;
  int level[MAXN];
  memset(level,0,sizeof(level));
  memset(tree,0,sizeof(tree));
  scanf("%d",&n);
  for(i=1;i<=n;i++)
  {
      int x,y;
      scanf("%d%d",&x,&y);
      x++;
      level[sum(x)]++; //一开始不算自己,因为考虑的是之前的数
      CreateTree(x,1);
  }
  for(i=0;i<n;i++)
  printf("%d\n",level[i]);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81023354