Stars (POJ - 2352)(线段树or树状数组)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yuewenyao/article/details/81132467

Stars题目链接

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

扫描二维码关注公众号,回复: 4924872 查看本文章

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

这个题可以用线段树写,也可以用树状数组写。

题意:这就是让我们求每个小星星左下角的星星的个数。

    我们可以按照y升序,y相同的x升序的顺序给出,由于y轴的已经排好序,我们可以根据x轴的坐标来建一个一维树状数组。

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

const int maxn = 30050;
int c[maxn] , a[maxn];

int lowbit(int x)
{
    return x & (-x);
}

int sum(int i)
{
    int s = 0 ;
    while(i > 0)
    {
        s += c[i];
        i -= lowbit(i);
    }
    return s;
}

void add(int i , int v)
{
    while(i <= maxn){
        c[i] += v ;
        i += lowbit(i);
    }
}

int main()
{
    int n , x  , y ;
    while(cin>>n)
    {
        memset(c , 0 , sizeof(c));
        memset(a , 0 , sizeof(a));
        for(int i = 0 ; i < n ; i ++)
        {
            scanf("%d%d",&x,&y);
            int tmpe = sum(x + 1 );
            a[tmpe] ++ ;
            add(x + 1 , 1 );
        }
        for(int  i = 0 ; i < n ; i ++)
            printf("%d\n",a[i]);
    }
    return 0 ;
}
 

猜你喜欢

转载自blog.csdn.net/yuewenyao/article/details/81132467
今日推荐