Andy's First Dictionary

Description
XY学长刚刚立下了再不过CET就直播xx的flag,为了不真的开启直播模式,XY学长决定好好学习英语。于是他每天都读一篇只包含生词的英语文章,并以自己高达450的智商在一秒钟之内记忆下来。

现在给你一篇XY学长今天要读的文章,请你写一个程序,输出他都学习到了哪些单词。
要求:如果文章中有相同的单词,那么仅仅输出一次;而且如果两个单词只有大小写不同,将他们视为相同的单词。
Input
测试数据将输入一篇文章。不超过5000行,每一行最多200个字符,并以EOF结束。
Output
按照字典序输出他学到的单词,每行输出一个单词,输出单词时所有的字母全部小写。
数据保证最多有5000个需要输出的单词。
Sample Input
样例输入①
a a a a a a a a, a a a a a a.
a a a a b a a a. a? a!!!
样例输入②
Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”

So they went home.
Sample Output
样例输出①
a
b
样例输出②
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
Hint
输入可能包含标点符号,但标点符号显然不能算作单词的一部分。

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;
set<string> dict;
int main()
{
    string s,buf;
    while(cin>>s)
    {
        for(int i=0; i<s.length(); i++)
            if(isalpha(s[i])) s[i]=tolower(s[i]); 
            //判断是否是字母,并且转化为小写字母
            else s[i]=' ';
        stringstream ss(s); 
        //去掉空格
        while(ss>>buf) dict.insert(buf);
        //写入集合
    }
    for(set<string>::iterator it=dict.begin(); it!=dict.end(); ++it)
        cout<<*it<<"\n";
    return 0;
}

这个书本上的代码。

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81149364
今日推荐